Skip to main content

C чего начать

Обзор Bootstrap, в том числе, как загрузить и использовать его, некоторые основные шаблоны и примеры, и многое другое.

Загрузка

Bootstrap v4.0.0-alpha.4 можно загрузить несколькими способами, в том числе некоторые из ваших любимых менеджеров пакетов. Выберите один из вариантов ниже, чтобы поймать то, что вам нужно.

Исходные файлы

Скачать все: источника Sass, JavaScript, и файлы документации. Требуется Sass компилятора Autoprefixer, что postcss-flexbugs-исправления и некоторые установки.

Скачать исходники

Менеджеры пакетов

Тянуть в Bootstrap исходные файлы В почти любой проект с одними из самых популярных пакетных менеджеров. Неважно, менеджер пакетов, Bootstrap будет Требуется Sass компилятора Autoprefixer, и что postcss-flexbugs-исправления для настройки, которая соответствует нашим официальным скомпилированные версии.

Внимание! Не все пакетные менеджеры имеют v4 alpha опубликован, но вскоре мы должны получить их!

npm

Установить Bootstrap в узел приложений с нпм пакет:

$ npm install bootstrap@4.0.0-alpha.4

require('bootstrap') загрузит все Bootstrap jQuery плагины на объект jQuery. На bootstrap сам модуль ничего не экспортировать. Вы можете вручную загрузить Bootstrap jQuery плагины индивидуально загрузки /js/*.js файлы верхнего уровня пакета каталог.

Bootstrap package.json содержит некоторые дополнительные метаданные в следующих разделах:

  • sass - путь к Bootstrap главным источником Sass файл
  • style - путь к Bootstrap не сжатый CSS, который был предварительно скомпилированные с использованием параметров по умолчанию (без настройки)

RubyGems

Установить Bootstrap В Ruby приложений с помощью Bundler (рекомендуется) и RubyGems, добавив следующую строку в ваш Gemfile:

gem 'bootstrap', '~> 4.0.0.alpha3'

Кроме того, если Вы не используете Bundler, можно установить gem выполнив следующую команду:

$ gem install bootstrap -v 4.0.0.alpha3

Смотри gem README для получения дополнительной информации.

Метеор

$ meteor add twbs:bootstrap@=4.0.0-alpha.4

Composer

Вы также можете установить и управлять Bootstrap Sass и JavaScript через Composer:

$ composer require twbs/bootstrap:4.0.0-alpha.4

Bower

Установите и управляйте Bootstrap Sass и JavaScript через Bower.

$ bower install bootstrap#v4.0.0-alpha.4

NuGet

Если вы разрабатываете в .Net, Вы также можете установить и управлять Bootstrap CSS или Sass и JavaScript через NuGet:

PM> Install-Package bootstrap -Pre
PM> Install-Package bootstrap.sass -Pre

В -Pre необходима до Bootstrap v4 имеет стабильный релиз.